What are the technical requirements for my Android device?

To start enjoying the FOX App on your Android device, download the app from the Google Play store.

Minimum requirements 

The FOX App is available on smartphones and tablets that run Android 4.1 or higher with medium (mdpi), high (hdpi), or extra-high (xhdpi) pixel densities. In general, if your tablet doesn’t show the application in Google Play, your device probably does not support it. If you have trouble downloading the application, we recommend updating your version of Android.

Exceptions

The FOX App contains certain security features that protect our content and are required by the studios. Certain Android devices are not compatible with this technology and cannot download the app or stream videos.

Devices incompatible with the Google Play Store

Android-powered devices that are incompatible with the Google Play Store are incompatible with the FOX App. If you have questions about whether your device is compatible, click here>

IMPROVE YOUR FOX MULTISCREEN VIEWING EXPERIENCE